Latest Listings In Category - General http://www.projoom.com Fri, 18 Aug 2017 18:46:38 +0100 FeedCreator 1.7.3 Where can I find documentation? http://www.projoom.com/component/kb/article/where_can_i_find_documentation.html <p>This article applies to all extensions.</p> <hr width="100%" size="2" /><br /><p>Access the module backend and look for the picture on the left.</p> <p> </p> <p style="text-align: center;"><img style="vertical-align: middle;" alt="dox1" src="images/stories/dox1.png" width="400" height="325" /></p> 62 Thu, 01 Jan 1970 00:00:00 +0100 Warning: touch() [function.touch]: Unable to create file http://www.projoom.com/component/kb/article/warning_touch()_[function.touch]_unable_to_create_file.html <p>Applies to some extensions.</p> <hr width="100%" size="2" /><br /><p>If you see this error, you might need to set some custom permissions or fix your FTP details.</p> <p>Please read the error carefully and find out which folder needs to be chmoded to 755.</p> <div>Ex. : Unable to create: /.../<strong>engine</strong>/....xml</div> <div>or</div> <div>Ex. : Unable to create /cache/<strong>mod_ABC</strong>/...xml configuration file.</div> <p>In this case you'll need to fix permission on the <strong><em>engine</em></strong> or <strong><em>cache </em></strong>folder or check your FTP Settings from Global Configuration (Server tab).</p> <p>If you don't know what CHMOD is or how to handle permissions, <a href="http://webmastertips.us/articles/tutorials/chmod.htm" target="_blank" title="How to...">click here.</a></p> <p>Please also check <a target="_blank" href="http://forum.joomla.org/viewtopic.php?t=121470">this link</a> for more details.</p> <p>If the above fails, you should change the permission to 777 but please read the note below.</p> <div>We don't recommend setting a 777 permission on any of your folder since it's not safe but if this is the only way it works, your server configuration might be wrong. Please contact your hosting company for support on setting up your account.</div> <div></div> 62 Thu, 01 Jan 1970 00:00:00 +0100 The extension X doesn't work http://www.projoom.com/component/kb/article/the_extension_x_doesnt_work.html <p>Applies to some extensions </p><hr width="100%" size="2" /><br /> <p>If extension X doesn't work on your site/page make sure you :</p><ul><li>Installed, configured and published the extension.</li><li>Watched/read the provided documentation.</li><li><strong><font color="#800000">You are not testing on localhost.</font></strong></li></ul><p>Some extensions aren't working while testing on localhost/local servers.</p><p>Please make sure you install and test on a live domain/server. </p> 62 Thu, 01 Jan 1970 00:00:00 +0100 The descriptions, links and titles reappears http://www.projoom.com/component/kb/article/the_descriptions,_links_and_titles_reappears.html <p>Applies to some extensions</p> <hr width="100%" size="2" /><br /><p><span style="color: #999999;">When I delete the description and apply or save the description reappears. Why?</span></p> <p>By default, the extension installs some demo descriptions, images, links, to help you understand how you should use the extension, what and where to insert.</p> <p>From now on the demo data removal is automated. Once installed, switch the setting Delete Demo data? to Yes and publish.</p> <p><span style="color: #888888;"><span style="font-size: 8pt;">Note : That setting will disappear from the menu configuration because there is no demo data.</span></span></p> 62 Thu, 01 Jan 1970 00:00:00 +0100 No output on some browsers http://www.projoom.com/component/kb/article/no_output_on_some_browsers.html <p>This issue is related with Artisteer templates.</p> <hr /><br /><p>Solution 1 :</p> <ol> <li>Open the <span style="color: #ff0000;"><strong>/templates/your_template/index.php</strong></span> file on your server with a text editor,</li> <li>Search for this line and comment/delete it: <em>swf.switchOffAutoHideShow();</em></li> <li>Save your file and refresh the page<em>.</em></li> </ol> <p>Solution 2 (recommended) :</p> <ol> <li>Open the <span style="color: #ff0000;"><strong>/templates/your_template/index.php</strong></span> file on your server with a text editor,</li> <li>Look for these lines : <br /> <pre><span style="color:#900">&lt;script type="text/javascript" src="/templates/your_template/swfobject.js"&gt;</span><span style="color:#900">&lt;/script&gt;</span><br /><span style="color:#900">&lt;script type="text/javascript"&gt;</span><br />jQuery((function (swf) {<br /> return function () {<br /> swf.switchOffAutoHideShow();<br /> swf.registerObject("object", "9.0.0", "/templates/your_template/expressInstall.swf");<br /> }<br />})(swfobject));<br /><span style="color:#900">&lt;/script&gt;</span> </pre> </li> <li>Comment/delete this code : <em>swf.switchOffAutoHideShow();</em></li> <li>Move the rest of the lines right above this one <span style="color:#900">&lt;/head&gt;</span></li> <li>Save your file and refresh the page<em>.</em></li> </ol> <p>Solution 3 :</p> <ol> <li>Open your ProJoom module</li> <li>Look for the option called "<em>Load SWFObject</em>" (on some modules this option is located inside the <em>Advanced Parameters </em>section)</li> <li>Switch it to "<em>Safe</em>"</li> <li>Save and refresh your front page.</li> </ol> 62 Thu, 01 Jan 1970 00:00:00 +0100 Multiple instances http://www.projoom.com/component/kb/article/multiple_instances.html <p>How to publish more than one instance of a module on the same page or across the website, using separate settings?</p> <hr width="100%" size="2" /><br /><div>1. In the modules list, click and check the select box of the module name.</div> <div>2. Click the Copy button in the upper right.</div> <div>3. You will create a clone.</div> <div>4. Configure the clone as a new module, change the settings as you need and publish it on another position or page.</div> <div></div> <div>For any additional instances, use the same steps.</div> 62 Thu, 01 Jan 1970 00:00:00 +0100 Warning! Failed to move file. http://www.projoom.com/component/kb/article/warning_failed_to_move_file..html <p>Joomla keeps telling me that when I try to install your extension.</p> <hr width="100%" size="2" /><br /><p>It's because your configuration is bad.</p> <p>Please log in to your Joomla backend and :</p> <ul> <li>Help -&gt; System Info</li> <li>Click on "Directory Permissions" </li> </ul> <p>Make sure there are <strong>NO</strong> unwritable (marked with <strong><span style="color: #ff0000;">red</span></strong>) folders.<br />Log in to your server and change your permissions accordingly.</p> <p>Try to install again.</p> 62 Thu, 01 Jan 1970 00:00:00 +0100 I need customization or changes http://www.projoom.com/component/kb/article/i_need_customization_or_changes.html <p>What if I need some change in functionality, look &amp; feel, custom work?</p> <hr width="100%" size="2" /><br /><p>Please do write and tell us your needs. If it's a good idea or a nice feature we will try to implement it.</p> <p><strong>Note : Remember you bought the product as described at that moment.</strong><br /><strong>We cannot <span style="color: #800000;">guarantee or accept</span> any of your feature request, change, etc. </strong></p> 62 Thu, 01 Jan 1970 00:00:00 +0100 How to upgrade http://www.projoom.com/component/kb/article/how_to_upgrade.html <p>I see there is a new version available. How to upgrade and preserve my settings?</p> <hr width="100%" size="2" /><br /><div> <p>Upgrading to a new version is simple and straight forward. <strong>You only need to install the new version over the old version.</strong></p> </div> <div> <p><strong><a target="_self" title="Sign in to your account" href="shop/account.php?action=view_orders">Click here</a></strong>, sign in using your e-mail and password. Follow the installation instructions from <strong><a target="_blank" href="shop/account.php?action=view_orders">your account</a>.</strong></p> </div> <div> <p>Installing a new version over an old version will upgrade the product so just install as normal then check your product version.</p> </div> <br /> <div><span style="color: #ff0000;"><span style="font-size: 8pt;"><strong>Note : It's always a good idea to check the product change log (see product page) before upgrading.</strong></span></span></div> <div><span style="color: #ff0000;"><span style="font-size: 8pt;"><strong>If you have questions regarding the upgrades, please use the <a title="Support" href="index.php?option=com_mad4joomla&amp;jid=1&amp;Itemid=97">SUPPORT</a> form to contact us.</strong></span></span></div> 62 Thu, 01 Jan 1970 00:00:00 +0100 Unable to write entry http://www.projoom.com/component/kb/article/unable_to_write_entry.html <p>This error appears if you use an old version of Joomla! (1.5.9 or older)</p> <hr width="100%" size="2" /><br /><p>If you receive this error while trying to install a product, please first see <a href="knowledgebase/article/warning_failed_to_move_file..html">this article</a>.</p> <p>The second option is to use <a target="_blank" href="http://extensions.joomla.org/extensions/core-enhancements/installers/9332">this component (click here)</a> to automate the upgrade to the latest Joomla! version.</p> <p>The third option is to manually update your Joomla! version to the latest.</p> <ol> <li><a target="_blank" href="http://joomlacode.org/gf/project/joomla/frs/?action=FrsReleaseView&amp;release_id=10786">Click here</a> and get your upgrade pack</li> <li>Unzip the file on your PC / Mac to a temporary folder</li> <li>Log in to your Joomla! Backend and put your site Offline.</li> <li>Connect to your server with a FTP client.</li> <li>Upload / Overwrite the files on your server.</li> <li>Put your site back Online.</li> </ol> <p>Once you run the latest Joomla! version, try to install again.</p> <p>The error should be gone.</p> 62 Thu, 01 Jan 1970 00:00:00 +0100 Warning: html_entity_decode() expects parameter 1 to be string http://www.projoom.com/component/kb/article/warning_html_entity_decode()_expects_parameter_1_to_be_string.html <p>This is a temporary warning. Read below.</p><hr width="100%" size="2" /><br /> <p>This is common for Pro Sticky Message and Pro Perfect Karousel and shows up if you don't follow the install procedure. For Sticky Message is enough to open the module and Save or Apply once.</p><p> See the documentation provided (or link to the documentation) and you'll discover that you missed a step.</p><p>The warning will be gone as soon as you follow the instructions (which are straight and simple). </p> 62 Thu, 01 Jan 1970 00:00:00 +0100 Module in content or article http://www.projoom.com/component/kb/article/module_in_content_or_article.html <p>I need to include your module inside an article. Is this possible?</p> <hr width="100%" size="2" /><br />Yes. <a href="http://www.joomlaspan.com/general/include-any-module-within-content-in-joomla-15.php" target="_blank">Click here</a> or <a target="_blank" title="How do you put a module inside an article?" href="http://docs.joomla.org/How_do_you_put_a_module_inside_an_article%3F">here</a> to read about how to do it. 62 Thu, 01 Jan 1970 00:00:00 +0100 Where should I get support? http://www.projoom.com/component/kb/article/where_should_i_get_support.html <p>Please see the above menu. Click the <strong>SUPPORT</strong> menu link.</p> <hr width="100%" size="2" /><br /><p>99% of the customer problems are solved in less than 24 hours.</p> <p>We have noticed that the issues are related mostly to human error, not our code. Note that we're not here to teach you Joomla.</p> <p>Support questions sent from :</p> <p>1. Contact form (CONTACT menu) will delay your problem being solved. On that page we specify NOT to use the form to ask for support.</p> <p>2. Shop (Manage Your Account) are not meant for product support.</p> 62 Thu, 01 Jan 1970 00:00:00 +0100 JFolder::files: Path is not a folder http://www.projoom.com/component/kb/article/jfolderfiles_path_is_not_a_folder.html <p>This is a temporary warning that may appear for 3 extensions. Please read the article.</p><hr width="100%" size="2" /><br /> <p><strong style="font-size: 14px">Pro Sticky Message</strong></p><p>Please install the component and the warning will disappear. </p><p><strong style="font-size: 14px">Pro Ultra Spinner<br /></strong></p><p>Install the module and publish it without changing anything. Browse the page where you published it then return to the module configuration page and press apply. </p><p><strong style="font-size: 14px">Pro Perfect Karousel </strong></p> Install the module and publish it without changing anything. Browse the page where you published it then return to the module configuration page and press apply.<p>&nbsp;</p><p>&nbsp;</p> 62 Thu, 01 Jan 1970 00:00:00 +0100 Can I use any of the products on another framework / static page? http://www.projoom.com/component/kb/article/can_i_use_any_of_the_products_on_another_framework___static_page.html <p><strong>No</strong>. The products are designed exclusively for Joomla.</p><hr width="100%" size="2" /><br /> <p>Please do not ask for support or require assistance about working with the products on some other framework / CMS / static page.</p><p align="center"><font color="#ff0000"><strong>You can install and work with them on Joomla CMS </strong></font><font color="#ff0000"><strong> only</strong></font><font color="#ff0000"><strong>! </strong></font></p> 62 Thu, 01 Jan 1970 00:00:00 +0100 J.parentNode is null or not an object http://www.projoom.com/component/kb/article/j.parentnode_is_null_or_not_an_object.html <p>I see this message if I check the Internet Explorer webpage error log.</p> <hr width="100%" size="2" /><br /><p>This error appears only if you have the swfobject.js script included <span style="color: #ff0000;"><strong>twice</strong></span> in your page. To fix it you have 2 options :</p> <ol> <li>Publish the first instance of the extensions with the option <strong>SWFObject Script</strong> (or <span><strong>Load SWFObject</strong>) </span>set to <strong>Mode 1</strong> or <strong>Mode 2</strong> (or <strong>Yes (local v2.1)</strong>,<strong>Yes (local v2.2)</strong>)and the next instances to Mode 3 (or No)</li> <li>Use the option <strong>SWFObject Script</strong> (or <span><strong>Load SWFObject</strong>) </span>set to <strong>Safe (or </strong>Safe embed).</li> </ol>It's also possible that you already have the file included by some other extension. Please check the page before deciding what option to use. 62 Thu, 01 Jan 1970 00:00:00 +0100 HTTP Errors http://www.projoom.com/component/kb/article/http_errors.html <p>I receive a 4xx, 5xx error. Can you help?</p> <hr /><br /><div>There are serveral reasons why such an error appears :</div> <div>1. A misconfigured .htaccess</div> <div>2. Server configuration / protection rule</div> <div></div> <div></div> <div>Please <a target="_blank" href="http://en.wikipedia.org/wiki/List_of_HTTP_status_codes">check here</a> the list of all HTTP errors.</div> <div>If you receive a 4xx or a 5xx error while using one of our products, it's <strong>NOT </strong>caused by our product. You will need to contact your hosting company and inform them about your problem.</div> <div></div> 62 Thu, 01 Jan 1970 00:00:00 +0100 PHP Warning: is_writable() ... open_basedir restriction in effect http://www.projoom.com/component/kb/article/php_warning_is_writable()_..._open_basedir_restriction_in_effect.html <p>I'm receiving this (or similar) warning message after I published your product. Why?</p> <hr /><br /><div>It's a common problem for Joomla! sites hosted on IIS or Plesk servers. Any ProJoom product will function correctly on any host if the server is fully Joomla! compatible.</div> <p>For a possible fix, see <a target="_blank" href="http://forum.joomla.org/viewtopic.php?f=543&amp;t=363858">this link</a> or <a target="_blank" href="http://forum.joomla.org/viewtopic.php?f=267&amp;t=262611">read here</a>.</p> <p><strong><span style="color: #888888;"><span style="font-size: 8pt;">Please note : We test our products on both Linux (Apache) and Windows (IIS 6 / 7) servers.</span></span></strong></p> 62 Thu, 01 Jan 1970 00:00:00 +0100 404 Page Not Found http://www.projoom.com/component/kb/article/404_page_not_found.html <p>How do I get this working?</p> <hr /><br /><p>Please <span style="color: #ff0000;"><strong>DON'T</strong></span> use the menu to link to the ProJoom components. If you need to display the output on a page, use the module(s) or the plugin(s) included.</p> <p>The ProJoom components are meant for backend management not for frontend use.</p> 62 Thu, 01 Jan 1970 00:00:00 +0100 Menu opens under the slide show http://www.projoom.com/component/kb/article/menu_opens_under_the_slide_show.html <p>Yes, there's a fix available from Adobe.</p> <hr /><br /><div>If you're running a 64bit OS (specially Windows) and your browser uses an outdated Flash Player please <a target="_blank" title="Download Adobe Flash Player" href="http://get.adobe.com/flashplayer/">click here</a> to update to the latest version.</div> <div></div> <div>The problem should now be gone.</div> 62 Thu, 01 Jan 1970 00:00:00 +0100 Error building Admin Menus http://www.projoom.com/component/kb/article/error_building_admin_menus.html <p>If you receive this error (or an SQL error starting with "Unknown column 'a.id'") is because you have previously tried to install the J!1.5 version of the product on a J!1.6 / 1.7 / 2.5 website.</p> <hr id="null" /><br /><div>First, we would like to clearly state that this issue is <span style="color: #ff0000;"><strong>NOT </strong></span>related with the product. It is a problem with the Joomla! 1.6 (or higher) core.</div> <div>Information is available <a target="_blank" href="http://joomlacode.org/gf/project/joomla/tracker/?action=TrackerItemEdit&amp;tracker_item_id=25516">here </a>and <a target="_blank" href="http://forum.joomla.org/viewtopic.php?p=2698581">here</a>.</div> <div></div> <div>You may receive this error if :</div> <div><ol> <li>You've tried to install the J!1.5 version of the product on a J!1.6 (or higher) website</li> <li>You've upgraded your website from J!1.5 to J!1.6 (or higher) and you had previously installed one of our products.</li> </ol></div> <div></div> <div>We do provide an easy and fast solution, so if you have troubles installing the J!1.6 (or higher) version of any of our products, please use the <strong><a href="index.php?option=com_mad4joomla&amp;jid=1&amp;Itemid=97">SUPPORT</a></strong> form to contact us and we'll guide you as fast as possible.</div> <div></div> <div></div> <p><span style="color: #808080;"><strong><span style="font-size: 8pt;">Note : All our Joomla! 1.5 products have been modified to prevent installation on a Joomla! 1.6 (or higher) website.</span></strong></span></p> <div></div> 62 Thu, 01 Jan 1970 00:00:00 +0100 Does your extensions support localhost servers? http://www.projoom.com/component/kb/article/does_your_extensions_support_localhost_servers.html <p>Of course they do! <hr /> </p><br /><p>It's a non-sense to say they don't,, since development is done on a localhost server then final tests on a live website.</p> <p>Note though, that we cannot assist you in solving a problem if our products are installed on a website we cannot reach, but please contact us to let us know if you need assistance.</p> 62 Thu, 01 Jan 1970 00:00:00 +0100